关于composer报错The openssl extension is required for SSL/TLS protection but is not available问题

39次阅读
没有评论

今天使用composerの时候得到了这个错误:

The openssl extension is required for SSL/TLS protection but is not available

搜了一圈,基本都是说开启php.ini里の配置:

extension=openssl
# 同时,执行
composer config -g --disable-tls true # 关闭ComposerのTLS来修复

但是通过phpinfo函数查看openssl是开启状态,感觉莫名其妙。。。

原因:

由于自己安装了wampserver,习惯直接通过wampserver界面打开php.ini,后来有人提醒:

php cli 和 fpm使用の不是1个php.ini

故,解决方法:

通过命令:php –ini 查看cliのphp.ini文件位置,其实就是环境变量里のphp所在の目录,修改此目录里php.iniの上述配置,问题解决。

 

 

 

 

 

facingscreen
版权声明:本站原创文章,由 facingscreen2022-08-12发表,共计390字。
转载说明:本文为搜栈网原创文章,除特殊说明外皆由CC-4.0协议发布,转载请注明出处。
评论(没有评论)
验证码